mirror of
https://github.com/MichaelFisher1997/nixos.git
synced 2025-04-26 22:23:10 +00:00
22 lines
498 B
Nix
22 lines
498 B
Nix
#this might be redundent
|
|
{config, pkgs, callPackage, ... }:
|
|
{
|
|
services.xserver = {
|
|
enable = true;
|
|
|
|
desktopManager = {
|
|
xterm.enable = false;
|
|
};
|
|
|
|
windowManager.i3 = {
|
|
enable = true;
|
|
extraPackages = with pkgs; [
|
|
dmenu #application launcher most people use
|
|
i3status # gives you the default i3 status bar
|
|
i3lock #default i3 screen locker
|
|
i3blocks #if you are planning on using i3blocks over i3status
|
|
picom
|
|
];
|
|
};
|
|
};
|
|
} |